Cant seem to find a good carb or is it something else?? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Sep 8th, 11, 09:06 AM Thread Starter
Tech Team
 
Join Date: Feb 2004
Posts: 83
Cant seem to find a good carb or is it something else??

Hey guys I have a problem with my corvette ( I know this is camaro world but I think the problem Im having can be with any car so please here me out.) I have a 66 vette that I've had 5 different carbs on and they all have a flooding and hesitation problem. the original 600 carb has a new kit in it and it floods as do almost every 600 I,ve ever had did and 3 new out of the box 670 holleys and 1 650 new holley does. They all run gas in after the engine is shut off and others blow gas out the top. I have adjusted the floates which helps for a little while then it happens again and mind you the float level is way lower than the sight plug hole. the fuel pressure is 5 Lbs and is a stock fuel pump. anyone with any Ideal of what might be causing this I,m listing. keep in mind I have messed around and built cars for 40 years from the ground up but this is strange. Thanks
POCO is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Sep 8th, 11, 09:24 AM
Tech Team
Dave
 
Join Date: Jun 2009
Location: Nocal
Posts: 37
Re: Cant seem to find a good carb or is it something else??

I fought a similar problem for some time on my holley. Even tried a new carb. Turned out to be the fairly new fuel filter can. Took it off one day and found the inner filter media rattling inside. Tore it apart and saw it was coming apart and peices were getting into the needle and seat causing it to flood. It would run OK for awhile but I came to realize my trouble always seem to start after I ran it hard. My guess is the increased fuel flow flushed out filter media which lodged in the needle and seat. I replaced the filter and put the brass filters in both inlets at the carb. Been OK since.

Dave
stratrex is offline  
post #3 of 3 (permalink) Old Sep 8th, 11, 01:49 PM
Gold Lifetime Member
Matt
 
Join Date: Jul 2009
Location: Lauderhill, Florida
Posts: 1,020
Re: Cant seem to find a good carb or is it something else??

A hesitation on acceleration could be from the float being set to low or from the accelerator pump cam being out of adjustment. You might also need to step up the primary squirter size. I had the same problem with my Holley.Run the car,shut it down and the carb would flood out and my garage would stink of gas.It would also be hard to restart after that because of the flooding.It turned out to be fuel percolation in the bowls.I actually heard it gurgling one night after I pulled in the garage and shut it down. The fuel would boil and drip out of the vents and the boosters.I bought the heat shield kit from Holley which includes the heat shield(which goes down first)and the 1/4'' thick gasket that acts as an insulator that goes on top.I bolted this on and it solved my problem. You can pick this heat shield kit up from Summit or Jegs for about 30 bucks.Hope this solves your problem.

1969 SS Garnet Red X55 350 Factory 4 speed
12 Bolt 3.55 Posi
461 BBC TKO600
Matt 69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome