fuel pump hits cross member - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Aug 9th, 02, 09:50 PM Thread Starter
Senior Tech
 
Join Date: Mar 2001
Location: slaughters ky 42456
Posts: 238
I just got a chrome Eldebrock h/p mechanical fuel pump from Jegs.The problem is when I went to put it on it won't clear the crossmember on my 71 Nova.The stock one clears good.Also the Inlet port aims right towards the motor mount frame bracket,not that It really matters now.Have any of you had this problem with Camaros.If so where can I get a high performance pump that will fit?This might save a few of you guys a little grief.

------------------
69 Camaro SS 350 4 speed
71 Nova
gene stills is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Aug 10th, 02, 03:42 AM
Senior Tech
 
Join Date: Feb 2000
Location: McKinney, Tx
Posts: 3,557
Is this one of those pumps that can be moved by taking out all the little allen bolts, twisting it in the right direction, and reassembling? I thought I've read about that on this forum before? Did you search the archives? Might be an easy fix......KZ

------------------
John D. Smith
69 SS/396 CLONE!

<A HREF="http://hobbystage.net/camaro/69ss396" TARGET=_blank>Hobbystage Texas Tornado Website

</A>

North Texas Camaro Club
kz1000ltd is offline  
post #3 of 3 (permalink) Old Aug 11th, 02, 02:37 PM
Gold Lifetime Member
Rick
 
Join Date: Feb 2000
Location: Accord, NY
Posts: 4,815
I had that exact problem when I went to install a Carter pump. Turned out my car had mismatched engine/motor mounts. The short versions of each.With the correct setup, my motor was raised a good inch and everything fit fine. Sometimes interchangability works against us!

------------------
Rick Dorion
69 RS Conv,355,M20,4.10's and I don't worry about stone chips ( yet ).
RickD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome