Muncie 3spd making noises - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old May 11th, 02, 05:15 AM Thread Starter
Tech Team
 
Join Date: Feb 2001
Location: casper,wy,usa
Posts: 94
I have a 69 SS with the orig. Muncie heavy duty 3spd and its making some bad noises. I was wondering if anybody might have an idea whats wrong. There is a click noise when you first engage the clutch and then again when I accelerate. It also makes a clicking noise sometimes when just cruising. When cruising it almost sounds like something is spinning and hitting up against something else.Its getting worse as time goes on. I do have a M20 that I could put in it and I was wondering if that would be a straight swap?. I have picked up a correct Hurst shifter and mounting plate but I still need the linkage(if anybody has linkage they would sell let me know)Your guesses on the 3spd are appreciated. Steve
spb350 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old May 11th, 02, 09:29 AM
Senior Tech
 
Join Date: Feb 2000
Location: McKinney, Tx
Posts: 3,557
I give up, what's a Muncie 3 speed?

------------------
John D. Smith
69 SS/396 CLONE!
The Texas Tornado lives!

North Texas Camaro Club

Hobbystage stinks!
kz1000ltd is offline  
post #3 of 5 (permalink) Old May 12th, 02, 06:36 AM
Senior Tech
John
 
Join Date: Dec 2001
Location: Latonia Kentucky
Posts: 1,693
Have you checked the condition of the U-joints to see if that is where the noise is comming from?

Muncie HD 3 speed was option #MC1, only available in '69 SS. I would keep the trans if at all possible, as only about 3000 were produced.
Kyvox is offline  
 
post #4 of 5 (permalink) Old May 12th, 02, 07:24 AM
 
Join Date: Jan 2002
Posts: 1,035
It sounds more like a clutch related problem..Ya, I'd keep the HD 3-speed...M20's are much more common.
1967 Panther is offline  
post #5 of 5 (permalink) Old May 12th, 02, 07:27 AM
Senior Tech
 
Join Date: Feb 2000
Location: McKinney, Tx
Posts: 3,557
Wow, I learn something new on this site everyday!!!!

------------------
John D. Smith
69 SS/396 CLONE!
The Texas Tornado lives!

North Texas Camaro Club

Hobbystage stinks!
kz1000ltd is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome