Demon Carb Idle - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Apr 26th, 01, 12:34 PM Thread Starter
 
Join Date: Dec 2000
Posts: 14
Post

Ok, I am running a 355 chevy with L98 Alum heads, a 292 cam with a street deominator intake. Th400 w/ 2500 stall. Timing set 22 at idle with adj. vac on, 34 total. Car runs 8.2 in 1/8th. I have a 750 street demon w/mech secondaries. Now why I got a 750 not the 650 is I am going to build a 383 stroker and I want to use the carb on it.
The problem, It smells rich at idle only. After talking wiht demon on other issues. I have taken the carb apart cleaned it, changed the power valve to a 2.5. I still have a rich Idle. I have adjusted my idle by closeing both plates and opening them the same turns of the idle screws untill the idle comes up and is stable. I thought it was the pwr valve but I pluged an old one and put it in still rich. I need some help...

[This message has been edited by shadowjr (edited 04-26-2001).]

[This message has been edited by shadowjr (edited 04-26-2001).]
shadowjr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Apr 27th, 01, 03:21 AM
 
Join Date: Jan 2001
Posts: 367
Post

I was having the same problem. Here is a link to what we discussed. https://www.camaros.net/forum/Forum5/HTML/001059.html

------------------
383 Speed-O-Motive stroker kit with Speed Demon 750, RPM intake,Proform HEI dist.MSD6a box,World Products Sportsman II heads, ported and polished with 2.02/1.60 valves,64cc,TRW forged pistons with 10.7:1 compression, Comp Xtreme 284 cam,Crane pushrods, Comp Cam 1.6 full roller rockers,ATI damper, 40 series Flowmasters, 4.11 gears with TH350 and Hughes 3000 stall.Powertrax NoSlip Locker
Tracy Focht is offline  
post #3 of 4 (permalink) Old Jan 1st, 03, 05:47 PM
 
Join Date: Dec 2002
Location: sc
Posts: 6
hey shadowjr when u figure it out let me know my combination sounds identical to urs but i am having the exact same prob. i mean exact same. ive tried everything. any help would be appreciated
midnightcamaro is offline  
 
post #4 of 4 (permalink) Old Jan 2nd, 03, 07:14 AM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,529
Garage
Set the floats and everything else to manufactures spec's (BG supplies all the spec's in the paper that comes with the carb and in the video they provide as well) adhust both pri and sec throttle blade to uncover .020" of the transfer slot (it's .020" wide so adjust until you have a square shape showing), the carb has to be off the car to do this. Next leave the throttle blade adjustment screws (idle adjustment screws) alone and dial in your idle with the idle mixture screws. This is the BG recomended way and it works. Remember the Power valve doesn't affect idle inless it's blown or rated larger than the vacuum you pull at idle.

------------------
...Dennis
"The '69, the '96 our local club"
and the "daily driver"
DjD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome