Holley 4555 problem - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Oct 14th, 00, 07:56 AM Thread Starter
Senior Tech
John
 
Join Date: Jan 2000
Location: Rohnert Park, CA
Posts: 171
Post

Just rebuilt my 4555 and have everything set to spec. Engine runs a little rough above 1500 (surges slightly) however the big problem is after I shut it off the right rear secondary bleeds back into the venturi at the orifice just above the butterfly. it will continue to do this until the float bowl is emty. changed both power vavles but it still does it. Any help would be appreciated.

Thanks,

John
onemorecamaro is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Oct 15th, 00, 03:27 PM
Moderator
Bill
 
Join Date: Aug 1998
Location: Waldorf Md. USA
Posts: 3,280
Post

John,
It almost sounds like you have an incorrect gasket, or a gasket got torn while putting the carb together ? Take the secondary bowl back off and look real closely at the gasket surfaces. Make sure nothing is stuck to them that could be keeping the gasket from sealing properly. If you follow the passage that the gas is coming out of you should be able to find the problem. If you still have the old gaskets, compare them with the new ones. ALso, who's kit did you use ? Some of the gaskets out there are really junk ! I always use either a Holley kit or an AED kit, which has all Holley parts in it.
Hope this helps,

------------------
Bill Koustenis
Advanced Automotive Machine
Waldorf Md
BillK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome