Help with my engine - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Dec 6th, 01, 04:24 PM Thread Starter
DS
 
Join Date: Aug 2000
Location: S.C.
Posts: 4
Post

Sorry this will be so long but I hope you someone can help or get me pointed toward the right direction. My engine feels like it has plenty of power, but it will sometimes backfire through the carb. It is a 355 that has a comp magnum 305h cam, sportsman II heads, a holley street dom. tall intake, holley 3310 carb and mallory dual point dist. It has also been balanced. The engine was built by a very good engine builder. It has been broke in but not really ever been on the road. It has also been setting for awhile but ran often. Also the carb was a used carb. If anyone could tell me how to ajust it that would be great. Sorry if I left anything out, if I did let me know and I will try to let you know what it is. Btw I am really a newbe to this. Thanks very much
DS is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Dec 6th, 01, 05:49 PM
 
Join Date: Nov 2001
Posts: 138
Post

If it backfires when you 1st step on it is to lean on pump shot. If it has a 25 go to a 28. With this cam you need extra pump shot plus as much crank timing as it will take.(Be sure to disconnect vac. advance when setting time.)
jhow66 is offline  
post #3 of 6 (permalink) Old Dec 6th, 01, 06:38 PM
Senior Tech
 
Join Date: Jan 2001
Location: skiatook, ok
Posts: 3,692
Post

What compression/gears/convertor/etc are you running? I have seen a lot of cars with big cams and intakes (and the 305 magnum is definately a big cam) that will pop back thru the carb if they have insufficent stall speed in the convertor or too high of gears...no torque and a lot of load dont go together very well. What is your initial/total timing, power valve size, jetting, etc. It could just need some tuning.

------------------
'78 chevy truck-355, 9.4-1, vortec heads, XE268, vortec rpm intake, 750 edelbrock, flowtech headers and terminators.

'77 Nova-slowly progressing project.

'78 Nova-parts car?

'95 Lumina 3.4L DOHC 210hp daily driver

[This message has been edited by travis (edited 12-07-2001).]
travis is offline  
 
post #4 of 6 (permalink) Old Dec 7th, 01, 12:19 PM
Senior Tech
 
Join Date: May 2001
Location: Austin TX USA
Posts: 501
Post

Are you sure your spark timing is ok?
Sleepy-69 is offline  
post #5 of 6 (permalink) Old Dec 7th, 01, 04:19 PM Thread Starter
DS
 
Join Date: Aug 2000
Location: S.C.
Posts: 4
Post

Guys it has a 3000 stall in it. I had it cranked up today and it seemed that the carb was flooding out. It was burning very rich. it was still doing the popping back. But this time it seemed as if it was getting way to much gas. Thanks for the help so far.
DS is offline  
post #6 of 6 (permalink) Old Dec 8th, 01, 08:41 PM
Senior Tech
 
Join Date: Jan 2001
Location: skiatook, ok
Posts: 3,692
Post

Sounds like you have blown the power valve...1 good backfire is all it takes. Might want to make sure your float level is set correctly too.
travis is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome