97 LT1 runs hot when idleing - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 8th, 01, 03:40 PM Thread Starter
 
Join Date: Feb 2001
Location: Malvern, AR USA
Posts: 1
Post

Anyone know at what temp the cooling fans are supposed to kick on for a 1997 LT1? I was told by the local chevy dealer they don't come on until the engine hits 225F then cools to 210! Seems awful high to me.I've seen Jet's aftermarket fan switch for 93-95 LT1's that kick the fans on at 200 and cool to 185 - called Jet directly & they say they are not compatible with 97 models. Has anyone heard of an aftermarket switch for a 97 model?
97ESPZ28 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 8th, 01, 04:25 PM
 
Join Date: Jul 2000
Location: vacaville
Posts: 25
Post

I got mine from JEGS automotive and the have a web site. You can elevate this problem by running your ac or heat or defrost! In winter run your heater or defrost all the time just adjust fan speed and temp. In summer run air all the time and adjust fan speed and temp. It will always stay's low and will not run hot because when the heat or air is on or tricked to be on! IT automatically kicks on sooner.

mark
mark_dg is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome