backfire through the carb - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Oct 6th, 03, 05:56 PM Thread Starter
Tech Team
 
Join Date: Sep 2003
Location: vancouver, bc
Posts: 92
Question

i have a 67 camaro with a 350, it has a edelbrock 600 and it backfires through the carb when i floor it of the line. it only happens when when i hit it hard, otherwise its totally fine. what might be the problem?
thanks in advance
kilo_00 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Oct 7th, 03, 12:51 AM
Senior Tech
Steven
 
Join Date: Jan 2001
Location: Raleigh, NC
Posts: 1,046
Post

Try adjusting the linkage on the side oarb that controls the size of the squirt ( accelerator pump ). Look down the carb throat to make sure you are getting a suirt. If it is clogged or too small, your car basically takes in a gulp of air and will pop thru the carb . If this is not the problem, I would check that plugs wires are in proper sequence and I would re-check the timing...
sdtsdt is offline  
post #3 of 5 (permalink) Old Oct 7th, 03, 01:43 PM
 
Join Date: Aug 2003
Posts: 154
Post

I had a similar problem, but more chronic backfiring through carb. It turned out to be a vacuum leak. Has this been a long term problem, or just recently after changing something like intake manifold or carb. I had changed both, and in the process did not screw down far enough the vacuum "bung" for auto-trans. The rear of the carb was sitting on the "bung". It drove me nuts I took off carb and re-installed it along with intake manifold several times. Based on my experiance I would guess a vacuum leak of some sort.
WillS is offline  
 
post #4 of 5 (permalink) Old Oct 8th, 03, 10:40 AM
Gold Lifetime Member
Steve
 
Join Date: May 2001
Location: Clermont, FL
Posts: 296
Post

Have you checked your timing? I replaced my damper and it took me weeks to find out that the timing mark was off by 7 degrees, the location of the mark changed in the 60's and it's common to get the wrong mark. Also may want to check that your vacuum advance is dropping out fast enough when you punch it.

68 convertible
ccpeat is offline  
post #5 of 5 (permalink) Old Oct 8th, 03, 10:59 AM
Senior Tech
Matt
 
Join Date: Aug 2000
Location: East Haven, CT, USA
Posts: 330
Post

stupid question but did you plug the back of the carb where the power brake booster takeoff goes?

'68 Camaro SS. Dealer for American made performance & restoration parts.
Check my site
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chassisboy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome