67 327 rebuilt 650 holly bad fumes - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Apr 24th, 03, 04:25 PM Thread Starter
Team Member
Steve
 
Join Date: Apr 2003
Location: massachusetts
Posts: 10
Post

my 67 327 was professionally rebuilt 8 years ago. Still has zero miles on it. I just start it up every once in a while. Holly 650 was rebuilt one year ago. I just changed the oil again added some mystery oil to clean. When I start it up it's very bad fumes. Can't stand for long time. Burns your eyes. Could this be carb, or just not run enough?

Steve
67 RS 327 4sp
Steve Mourousas is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 24th, 03, 04:41 PM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,529
Garage
Post

Sounds like a bad power valve... Old gas is real bad on carbs and may be causing a float to stick or a lot of other internal carb issues.

IMO you are slowly killing your engine. You need to get out and run it and get the temps up if you want that mill to live. Damaging moisture and contaminates collect in the oil and won't burn off unless your engine is run for about 20 minutes at operating temp. You'd be better off preping the engine for storage and putting it away until your ready for it.

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
post #3 of 3 (permalink) Old Apr 27th, 03, 05:15 AM
SY1
Senior Tech
Dave
 
Join Date: May 2001
Location: Michigan
Posts: 2,920
Post

Ditto on what Dennis says. Regarding the power valve it may just be the wrong one for your application. check your vacum at idle and then pull the power valve out and check the number. If it is not 2 inches higher than the vacum you have at idle it could be opening and causing the overly rich condition you mention. This is particularly a problem if you have a large duration camshaft and the carb wasn't set up to match.

"..............what, and get out of aviation??"
SY1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome