Timing and advance - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jul 16th, 00, 01:52 PM Thread Starter
 
Join Date: May 2000
Posts: 67
Post

I have a new 383 motor in my 69 Camaro. It is 9.5 to 1 compression witht the entire Edelbrock RPM system (heads, manifold, 750cfm carb, cam). I have an hei distributor with a Mallory Coil and an MSD6 box. The motor has been overheating at idle, so I started taking a look at my timing and I am not sure what I need.

Here are my current specs...

At 600 rpm it is 10BTDC w/o the vac advance
At 1000rpm it is 10btdc w/o the vac advance
At 2000rpm it is 15btdc w/o the vac advance
At 2500rpm it is 18btdc w/o the vac advance
(All of these setting were with the vac. advance disconnected)

When I connect the vac advance I am at 20btdc at 1000 rpms.

How does this sound to you guys? What if anything do I need to adjust? How do I go about it?

Thanks in advance.

Mike

rlrr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jul 16th, 00, 04:25 PM
Tech Team
 
Join Date: Feb 2000
Location: El Cajon, Calif
Posts: 49
Post

I got basically the same 383 but 9.4 to 1 I got max power on the dyno with a total advance of 38 degrees.... sounds like you've got a problem with the dist.

------------------
keepin' it original 69Z
69-ZMAN is offline  
post #3 of 4 (permalink) Old Jul 17th, 00, 09:12 AM Thread Starter
 
Join Date: May 2000
Posts: 67
Post

A little bit of follow up, should total advance include th vac. advance or just the mechanical? Should I get a new set of springs for my distributor? At what rpm should total adavnce take place?

Thanks again.

Mike
rlrr is offline  
 
post #4 of 4 (permalink) Old Jul 17th, 00, 09:46 AM
 
Join Date: Jul 2000
Location: canada
Posts: 20
Talking

This should help put one light spring one heavey spring under roter.Start car bring to proper temp disconect vac line plug it hock up timing light rev up to 3000 rpm set timing at 35 degreas total tighten dist.Hock line up may idel a little high set idel to 850 rpms hopefulley you have timing tape around your balancer.If not advance timing just till it pings then back off a little till ping goes away if you advance to far as to it does not wont to fire retard timing a little but timing tape is the ticket.Don 396.
snake is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome