1984 camaro berlinetta no air/heat/fan - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jul 13th, 00, 04:32 AM Thread Starter
 
Join Date: Jul 2000
Location: Houston, Tx USA
Posts: 1
Unhappy

My 1984 camaro berlinetta's (305 V8 This camaro has the radio installed on a pedestal)air/heat/defrost/fan will not function. I checked the fuses and they all are fine. The head that controls the above functions also has the wiper controls on it and the wipers work. Any suggestions?
WAD77095 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jul 17th, 00, 04:02 AM
Senior Tech
 
Join Date: Mar 2000
Location: Dtown PA
Posts: 820
Post

sounds like a bad blower motor, disconnect the wires under the hood and hook a test light to them , or better yet, run them to the battery, if it comes on its a wiring problem, if it dont, then the blower motor is bad. its a start.

------------------
Chris's 67 RS can be seen at http://www.geocities.com/macphreak4evr/index.html
JOIN THE CAMARO NET WEBRING! www.geocities.com/macphreak4evr/webring/webringjoin.htm !!!

[This message has been edited by Chris Edwards (edited 07-17-2000).]
Chris Edwards is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome