New Air Compressor Cycling Too Much - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Mar 8th, 01, 03:28 AM Thread Starter
 
Join Date: Mar 2001
Location: Tampa, FL USA
Posts: 2
Post

I just had a new air compressor installed in my 95 Z28 and it cycles on and off every 5 to 10 seconds. The click is VERY AUDIBLE and VERY ANNOYING. This cannot be a good sign. Help! Does anyone know about this? Also, the car hesitates when it happens.
Ul2M8Cyn is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Mar 8th, 01, 04:31 AM
Senior Tech
 
Join Date: Jan 2001
Location: skiatook, ok
Posts: 3,692
Post

The freon is low...thats the only thing I know of that will cause that

------------------
375hp 78 Chevy truck
77 Chevy Nova
95 Chevy Lumina 3.4L
and building a 78 Nova
travis is offline  
post #3 of 4 (permalink) Old Mar 8th, 01, 07:35 AM Thread Starter
 
Join Date: Mar 2001
Location: Tampa, FL USA
Posts: 2
Post

Thanks, Travis. It turns out that the freon is low - from the evaporator springing a leak. Now the dealer says they have to replace the evaporator because the new compressor made the old evaporator leak. I told them to replace the hoses too - Do you know of any other part of the system that could break down now? I appreciate your help.

Ul2M8Cyn is offline  
 
post #4 of 4 (permalink) Old Mar 8th, 01, 12:48 PM
Senior Tech
 
Join Date: Dec 2000
Location: Monroe, WA, USA
Posts: 312
Post

IMHO get the recever/dryer changed too. if the new comp. caused the evaporator to spring a leak i bet you had a little corision going on. they are ALm. but if the drain hole get's pluged they will corrode. or if water get's in the system too.

the resion i say get the reciver dryer changed is this is a sign of contamination in the system and the reciever/dryer will colect and hold the contamination. it is about a $50.00 part and if they change the hoses and stuff you will probabvly not get a labor increse hopefully. when i wrenched i would not have charged you more with all you are getting done.
ilbl8 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome