RS turn signals - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Mar 8th, 04, 05:36 AM Thread Starter
 
Join Date: Nov 2003
Posts: 45
Question

Hi … have a problem …I am in the middle of putting the front end together on my rs … the problem is I have the turn signals, but the front valance has no holes or bracket or anything ells for the bolts to mount it up. I mean the holes for the light's are there … but nothing to bolt it up too. Am I missing a bracket or something that goes on the valance? I do have the real rs signals. Thanks for any help.
Ken/68RS is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Mar 8th, 04, 06:37 AM
Gold Lifetime Member
Paul
 
PDQUICK's Avatar
 
Join Date: Oct 2001
Location: Londonderry, NH
Posts: 1,010
Post

Sounds like you've got a 67 valance or lamps for your '68???? The '68 lamps and valence have the brackets built into them but the '67 lamps require an extra bracket to bolt to the earlier valance.

It sounds like some of your hardware is mis-matched??

Paul D.
PDQUICK is offline  
post #3 of 5 (permalink) Old Mar 8th, 04, 07:12 AM Thread Starter
 
Join Date: Nov 2003
Posts: 45
Post

Hhmm ..maybe I do… not sure now, what is the major diff between the two years?… other than one having a bracket and the other not.?... I know mine is a 68... not that clueless..Are the light's located in the same spot? I guess I need to look at a few and check it out … thanks for the clue Paul.
Ken/68RS is offline  
 
post #4 of 5 (permalink) Old Mar 8th, 04, 07:28 AM
Senior Tech
William
 
William's Avatar
 
Join Date: May 2000
Location: Waukesha WI
Posts: 2,938
Post

'67 RS lamps have a die-cast chrome housing that were retained in the valance by a clamp that mounted to the rear of the housing. A '67 valance will not have mounting brackets for the lamps.

'68 RS lamps have a smaller plastic housing featuring a molded tab with 2 holes. The '68 valance has a bracket that corresponds to the holes on the plastic housing.

William

CRG
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
William is offline  
post #5 of 5 (permalink) Old Mar 18th, 04, 09:14 AM Thread Starter
 
Join Date: Nov 2003
Posts: 45
Unhappy

Well it looks like I have 68 rs lights but a 67 front valance… kind of sucks.. Looks like I will be picking up a 68 valance… Cheaper of the two .....
Ken/68RS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome