Power steering pump noise??? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jan 30th, 01, 07:50 AM Thread Starter
 
Join Date: Dec 2000
Posts: 10
Question

There is a loud whirrling sound comming from my power steering pump, especically when it is humid. Its not the pully. Is there an easy way to fix it w/out replaceing the pump? I think it may be the bearings but Im not sure.
nrowland is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jan 30th, 01, 09:36 AM
Senior Tech
 
Join Date: Dec 2000
Location: Monroe, WA, USA
Posts: 312
Post

it can be the front bearing or the punmp it self, the by pass valve could be stuck and this causes a whine in the pump.

R&R the pump only way to fix it. sorry no fix in a bottle here. but make sure it is not the belt!

check the pully for a grove or a small nick. and the belt for glazing. also spray a little soapy water on the belt while runing. if it stop's makeing noise or get's quieter it is the pully/belt.
ilbl8 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome