TH350 leak? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Mar 30th, 00, 10:30 AM Thread Starter
 
Join Date: Mar 2000
Location: Corona, California, U.S.
Posts: 1
Question

Greetings everyone, this is my first time on this board. I recently purchased a 69 Camaro with a TH350. The other day I noticed a small puddle of fluid on the garage floor. Upon investigation, it seems to be dripping ever so slightly from a small rubber tube protruding through the underside of the torque converter. What is the purpose of this tube? Is there any cause for concern?
Ringannouncerjim is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Mar 30th, 00, 01:13 PM
Senior Tech
Steve
 
mccorry's Avatar
 
Join Date: Apr 1999
Location: Grove City, Ohio, USA
Posts: 1,658
Garage
Post

I don't follow what tube you are talking about. There shouldn't be any tube near the converter/flywheel. Main tubes and lines are the speedo cable, the vacuum modulator line, and the kickdown cable. Also have the cooler lines and the filler tube....

I'll send you an email also....

------------------
Steve McCorry - Central Ohio Camaro Club
'69 Camaro RS/SS-350 - Daytona Yellow
'95 Camaro Z-28 - Sebring Silver
click here to see my car ---> www.mindspring.com/~mccorry
mccorry is online now  
post #3 of 3 (permalink) Old Mar 30th, 00, 01:19 PM
Senior Tech
 
Join Date: Aug 1999
Location: Ontario, Canada
Posts: 564
Post

What a handle, welcome to the site,
I would be concered with any fluid leaking this is not normal, It will lead to bigger problems, I am not sure what you are describing where the leak is coming from, if the fluid is red in colour then it would be the trans fluid that is leaking, the only tube that I can think of is the vent tube at the top of the transmission, if the fluid is leaking from here check the fluid level, it may be overfilled, Check the fluid with the engine running in Park, Is it frothy and over the full Mark? If so then drain some out. If the fluid level is correct and the fluid is leaking from the venyt then it the trans might be over heating. Be sure to check it out, nothing worse than seeing a Camaro on the Hook, Ford guys love that, Sick puppies they are.
Rob.Canada is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome