MSD 6al cutting out - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 2nd, 03, 08:27 PM Thread Starter
 
Join Date: Jul 2000
Posts: 34
Post

I've had the 6al box in my '67 for a few years. Just recently, I've started having problems.

A few days ago, when I tried to start the thing, the starter just spins and there's no ignition. I got out my test light, turned the key to the on position, and there's no fire at the coil. A few days later I went out and checked for fire at the coil, and there was. Then it started right up. So I drove around for 20 minutes or so, and it died. Got out the test light, and again there's no fire at the coil.

So right now I'm thinking there's a loose connection in the box, possibly caused by corrosion due to condensation?

Before I pull it apart and look at it, I'd like to get some feedback from anyone who might have had this problem.

Thanks
ryskey67 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 3rd, 03, 01:59 AM
 
Join Date: Dec 2002
Posts: 169
Post

My 6AL box did that just prior to it dying. I went to MSD's website and tried their method of checking it and it showed the box was dead. I called them and confirmed this, and they told me I could send it in to them and they would rebuild it for not more than like $95 (I think was the amt), so I sent it in. In less than 2 wks it came back for much less than the max, about $55, good as new.

They told me a resistor or diode along with another wire, had shorted out.

It was actually a quick, reasonably priced fix if you ask me.
ztoy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome