Fuel Problem - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 5th, 00, 08:19 AM Thread Starter
 
Join Date: May 2000
Location: san jose, CA, usa
Posts: 15
Hey guys, I have a 91 Camaro RS w/305 TBI. It has run great till the other day. It will start and idle okay but when I rev it and hold the peddle (for example to 1500rpm) the revs will go up and down from about 1300 to 1500. At 2000rpm and up, it has very little power and is slow to rev up. It feels like it is out of gas when I floor it at higher rpms and sounds like it is bogging almost. I have headers and suspect a burnt vacuum line or something possibly?? When I hold it at ANY rpm, it has the same above problem, it jumps up and down as if the fuel is being turned on and off every half second. PLEASE HELP! THANKS!
LT1Steve is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 5th, 00, 09:54 AM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,140
The first thing is to change the fuel filter. A plugged fuel filter will cause it. And having a restricted fuel filter will make your fuel pump work harder, causing it to wear out sooner. If fuel pressure drops below around 28 lbs (I'm guessing) the injectors won't fire at all. If that does not help, check fuel pressure, buy a gage if you don't have one, it'l come in handy.
The parts guys tell me they see relay and fuel pressure regulator problems on these cars too.

I'm assuming you don't have any ignition problems that are causing it. Usually, you should make shure the ignition is working right first, then check the fuel system.
I've seen the brown wire for setting base timing partally plugged in and cause trouble. The smog test guy did it. The system goes from test mode to run mode and back. Pings a little and loss of power off and on.

David

------------------
The older I get, the faster I was!
davidpozzi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome