Weird Trouble - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Jul 29th, 00, 12:08 PM Thread Starter
 
Join Date: Jul 2000
Location: san pedro cal U.S.A.
Posts: 10
Post

Ive got a problem with my engine it basically can not idle. Now before this everything was running extremly well. It gets warm and then when it goes to idle it does then stumbles and dies. I dont know what it is. I havent started the engine up in just 2 days. I did see a little oil coming from from intake so it might be a vacuum problem but it did this to when the engine was running fine. So i don't know what to do your help would be greatly appreciated. The carburetor is brand new and the engine to.
powerHOUSE is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Jul 30th, 00, 06:34 AM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,073
Wink

Like a lot of posts here you are not giving enough information. It makes it difficult to help you.

What engine?
stock or modified?
If different cam what are the specs?
What type/year car?
What type ign? points, HEI or other?
Do you have an external fuel filter on the engine and what type? paper or screen?

Post the infor here and we'll try and help.
David

------------------
Check my web page for suspension info:
David's Homepage
67 RS 327
69 Camaro Vintage Racer
65 Lola T-70 Can Am Vintage Racer
davidpozzi is offline  
post #3 of 7 (permalink) Old Jul 30th, 00, 07:23 PM Thread Starter
 
Join Date: Jul 2000
Location: san pedro cal U.S.A.
Posts: 10
Post

Alright i have a 68 camaro with a 383 small block. I have a msd ready to run distributor and a fram fuel filter which is probably paper.I have a 750 db carburetor. I also have a comp cam extreme energy 284. Anymore needed information ill be glad to post. Oh and also i have a 2800 stall. Thanks
powerHOUSE is offline  
 
post #4 of 7 (permalink) Old Jul 30th, 00, 07:25 PM Thread Starter
 
Join Date: Jul 2000
Location: san pedro cal U.S.A.
Posts: 10
Post

The engine use to fire right up but now its hard. So the first thing im going to do is check the timing and the springs on my distributor.
powerHOUSE is offline  
post #5 of 7 (permalink) Old Jul 31st, 00, 02:46 PM
Tech Team
 
Join Date: Mar 1999
Location: College Park, MD USA
Posts: 42
Question

You said the carb is new? Did you adjust the idle mix screws when you installed it? When I got the carb on my 86 rebuilt, it would slowly lose RPM at idle until it stalled out completely. Turns out they didn't set the idle mix.

It's probably more complicated than that, just a thought.

Squirrels
squirrels is offline  
post #6 of 7 (permalink) Old Jul 31st, 00, 09:47 PM Thread Starter
 
Join Date: Jul 2000
Location: san pedro cal U.S.A.
Posts: 10
Post

yes i did. It has been running for 8 months very nicely. Until one day i started it and this happened thats why i said it was weird for.
powerHOUSE is offline  
post #7 of 7 (permalink) Old Aug 1st, 00, 04:25 PM
Tech Team
 
Join Date: Feb 2000
Location: pocatello id.
Posts: 59
Post

did you check for a vacuum leak ? start the car and put your hand over the top of the carb oh ya take the air cleaner off first if the engine starts to idle better what you have done is remove air from the engine and let it breath through the leak after you have determined it a leak take carb spray and spray arounr base of carb and intake manifold if it changes idle or you see air bubbles you found the leak also you might check for a blown power valve if it is a holley good luck
bruce ulrich is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome