69 speedo - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Dec 23rd, 02, 06:11 AM Thread Starter
 
Join Date: Sep 2002
Location: memphis tn us
Posts: 3
69 396 4 speed speedometer making noise and bouncing. has new cable fits fine.
jimbo0169 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Dec 23rd, 02, 10:27 AM
Gold Lifetime Member
John
 
Vintage 68's Avatar
 
Join Date: Mar 2002
Location: Moraga,Ca.,USA
Posts: 13,705
If you're positive that the cable is okay (check it really carefully for burs or rough spots), it's lubed correctly over the entire cable and that the cable housing is clean inside and has no dents or kinks - then it's probably the speedo head. The mag cup bearing points may be worn or dry causing the cup to drag on the magnet.

------------------
'68 Rag-top SS350/350 (on it's way to a 200-4R)

[This message has been edited by Vintage 68 (edited 12-23-2002).]
Vintage 68 is offline  
post #3 of 3 (permalink) Old Dec 23rd, 02, 11:51 AM
 
Join Date: Jan 2002
Posts: 1,035
I hate it when my cup drags..sign of old age...!
1967 Panther is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome