Stupid Horn Question ('84) - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Mar 29th, 00, 04:05 PM Thread Starter
 
Join Date: Jan 2000
Location: Phoenixville, PA 19460
Posts: 7
Question

Ok,

Here is a really stupid question, but maybe there is something i have missed. My horn will not work. I took the coverpiece off of the steering whell and i made sure that all the metal connectors were touching the steering column and all. I touched the contacts together and still nothing.

So, i went out and bought a replacement horn. I installed it, and STILL nothing. I know it can't be the fuse because i am 99% sure that it is on the same fuse as the headlights or the stereo (both of which work fine).

Any other ideas before i go ripping out wiring? BTW, Its an 84.
Dtaney is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Mar 29th, 00, 09:06 PM
 
Join Date: Dec 1999
Location: Gladstone, Mo
Posts: 21
Post

did you check all of the fuses? and check all the wiring? It is a very simple circuit. good luck.
josh
josh_sallee is offline  
post #3 of 5 (permalink) Old Mar 29th, 00, 09:37 PM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,080
Post

Check the horn relay.
davidpozzi is offline  
 
post #4 of 5 (permalink) Old Mar 30th, 00, 01:06 AM Thread Starter
 
Join Date: Jan 2000
Location: Phoenixville, PA 19460
Posts: 7
Post

Where is the relay located? I Can't find it.
Dtaney is offline  
post #5 of 5 (permalink) Old Mar 25th, 06, 07:42 PM
 
Join Date: Mar 2006
Posts: 4
Re: Stupid Horn Question ('84)

It's on the same fuse as the cigar lighter I think. At least it is on my 84. My contact broke off and the horn blew until the fuse blew. Then my cigar lighter wouldn't work either. Along with the interior lights.
shuanm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome