engine problems - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Feb 26th, 01, 08:09 AM Thread Starter
 
Join Date: Feb 2001
Location: virginia beach,va
Posts: 1
Angry

my 96 z28 has a surging problem,it surges with steady accelerator-usually around 30-55 mhp. have already had intake an injectors cleaned,spark plugs and wires changed,no engine light and no codes come up on the scanner and none in the history file either!. i am running out of ways to turn an money as well!-if anyone has seen this problem on the newer camaros or had it also,please key me in on the remedy,the car only has 55,000 miles on it. it's the 5.7 liter 350.
96 camaro z28 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Feb 26th, 01, 04:47 PM
Senior Tech
 
Join Date: Dec 1999
Location: Meridian, Idaho
Posts: 321
Post

It sounds like an injector is fouling and needs replaced. Been there and done it. If you are handy with an Ohm meter it should be about 20 Ohms. Compare all of them and you will find the culprit.
camaroguy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome