Turn signals..please help!! - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 7th, 01, 11:23 AM Thread Starter
 
Join Date: Sep 2000
Location: Athens, GA, USA
Posts: 26
Unhappy

Here's the problem...on my 69 both sets of turn signals blink whenever I select one or the other. Also, when the headlights are on, there is no taillight/running light. I've tried replacing the flasher and checking the wiring into the taillights. They worked fine about 3 months ago and now they are driving me crazy. The brake lights and hazards work fine. Anyone else had this problem???? Thanks!

[This message has been edited by budman93 (edited 05-07-2001).]
budman93 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 7th, 01, 12:05 PM
 
Join Date: Jun 2000
Posts: 93
Post

Check your grounds. When they're not good strange things happen. Pete

------------------
67 red camaro convertible, 78 silver anniversary vette, 1976 kz900, 1985 Z28 camaro, 1971 chevelle. Too many toys now My four car garage is no longer big enough.
no1dc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome