Turbo 350 - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jun 3rd, 12, 05:33 PM Thread Starter
Tech Team
Ron
 
Join Date: Jun 2012
Location: Mishawaka indiana
Posts: 40
Turbo 350

I have a question i have a 84camaro with a 350 turbo tranny thats stuck in first even after manual shifting from under the car what would cause the tranny to lock up like that?
Smith84 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jun 5th, 12, 12:32 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: Turbo 350

Bad govenor, or a stuck shift valve most likely. Good news is, the govenor is easy to get to with the tranny in the car. The valve body isn't too bad either, except you have to drain the fluid and remove the pan to get to it.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #3 of 5 (permalink) Old Jun 5th, 12, 02:45 PM
Gold Lifetime Member
Jeff
 
yellow69RS's Avatar
 
Join Date: Jul 2007
Location: Aurora, IL
Posts: 5,065
Send a message via Yahoo to yellow69RS
Re: Turbo 350

A vacuum modulator with no vacuum causes a late or never upshift. Hose off or line crimped shut? bad modulator?

Jeff
yellow69RS is offline  
 
post #4 of 5 (permalink) Old Jun 7th, 12, 02:43 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: Turbo 350

Good point Jeff...perhaps the easiest to check of all.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #5 of 5 (permalink) Old Jun 7th, 12, 04:29 PM Thread Starter
Tech Team
Ron
 
Join Date: Jun 2012
Location: Mishawaka indiana
Posts: 40
I had to slam it in park from reverse, lost brake pressure and that was the only way to get it to stop rolling

Sent from my SCH-R680 using AutoGuide.Com Free App
Smith84 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome