69 Camaro won't start - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Jun 7th, 12, 08:34 PM Thread Starter
Senior Tech
Mark
 
Join Date: Feb 2005
Location: Georgetown, TX
Posts: 335
Garage
69 Camaro won't start

I'm looking for a sanity check before I order a replacement coil for my 69 Camaro. It's been running fine until tonight.

Jumped in it tonight to go for a ride, and it wouldn't start. It turns over fine, but didn't act like it wanted to start once. Removed the air cleaner and verified the choke is closed and accelerator pump is squirting gas. Removed the coil wire from the distributor cap and cranked over the engine....no spark. Verified the coil is receiving 12 volts when the car is in start or run position. Verified the rotor is turning when the motor is spinning over. Disconnected the wires on the distributor side of the coil and put an ohm meter across the primary windings - measured about 24,000 ohms. I think that's way too high.

The Accel distributor I have requires a coil with primary windings of 1 ohm or less. The coil is a Pertronix Flame Thrower II, and if I remember correctly the primary side of the coil should measure 0.6 ohms. Am I missing something obvious, or do you think I'm in the market for a new coil? Sure looks like it to me.

It sure was a nice night to go for a cruise....

69 RS, Hugger orange/black, Deluxe interior, Sony AM/FM/XM/CD, PS & PB. 355, forged pistons, Eagle rods, balanced, Iron Eagles, 9.4:1 CR, .038 quench, XR270HR Cam, Z28 intake, FAST-EZ EFI 2.0, Thorley Tri-Ys, TCI 700R4, 2400 stall, 3.42 posi
LukeWarm is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Jun 8th, 12, 04:29 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,728
Garage
Re: 69 Camaro won't start

You would be correct, too high of resistance. Should be typically around less than 3 ohms.
Of course, you've taken and made sure of good contact of meter leads to the coil terminals and tested the meter on another known resistance just to make sure.
You may want to change out the coil to an Accel coil keeping the same brand for the whole system, keep all the plaers of the same brand.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
post #3 of 7 (permalink) Old Jun 8th, 12, 07:01 AM Thread Starter
Senior Tech
Mark
 
Join Date: Feb 2005
Location: Georgetown, TX
Posts: 335
Garage
Re: 69 Camaro won't start

Thanks for the input Everett.

69 RS, Hugger orange/black, Deluxe interior, Sony AM/FM/XM/CD, PS & PB. 355, forged pistons, Eagle rods, balanced, Iron Eagles, 9.4:1 CR, .038 quench, XR270HR Cam, Z28 intake, FAST-EZ EFI 2.0, Thorley Tri-Ys, TCI 700R4, 2400 stall, 3.42 posi
LukeWarm is offline  
 
post #4 of 7 (permalink) Old Jun 8th, 12, 04:35 PM
Senior Tech
Brian
 
PA Camaro Guy's Avatar
 
Join Date: Apr 2008
Location: PA
Posts: 642
Re: 69 Camaro won't start

Also- correct mounting position for oil filled coils- straight up. Can burn the windings if mounted laterally. No one ever is tempted to mount canister coils this way but worth reminder!

1969 Camaro 383
2.02/1.63 & 234/244 Vortec
TH350 / 12 bolt 3.73
PA Camaro Guy is offline  
post #5 of 7 (permalink) Old Jun 13th, 12, 09:23 PM Thread Starter
Senior Tech
Mark
 
Join Date: Feb 2005
Location: Georgetown, TX
Posts: 335
Garage
Re: 69 Camaro won't start

A new coil is just what the doctor ordered. Installed the replacement and it started on the first try.

69 RS, Hugger orange/black, Deluxe interior, Sony AM/FM/XM/CD, PS & PB. 355, forged pistons, Eagle rods, balanced, Iron Eagles, 9.4:1 CR, .038 quench, XR270HR Cam, Z28 intake, FAST-EZ EFI 2.0, Thorley Tri-Ys, TCI 700R4, 2400 stall, 3.42 posi
LukeWarm is offline  
post #6 of 7 (permalink) Old Jun 13th, 12, 09:53 PM
Gold Lifetime Member
Max Stewart
 
Join Date: Apr 2010
Location: Las Vegas, NV
Posts: 303
Send a message via Yahoo to bigbuckcity
Re: 69 Camaro won't start

So did you finally get to go cruisin!!!!!!!!!!!!!
bigbuckcity is offline  
post #7 of 7 (permalink) Old Jun 14th, 12, 09:39 PM Thread Starter
Senior Tech
Mark
 
Join Date: Feb 2005
Location: Georgetown, TX
Posts: 335
Garage
Re: 69 Camaro won't start

Yep!!!

69 RS, Hugger orange/black, Deluxe interior, Sony AM/FM/XM/CD, PS & PB. 355, forged pistons, Eagle rods, balanced, Iron Eagles, 9.4:1 CR, .038 quench, XR270HR Cam, Z28 intake, FAST-EZ EFI 2.0, Thorley Tri-Ys, TCI 700R4, 2400 stall, 3.42 posi
LukeWarm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome