New Brake System.. No Brakes? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Aug 11th, 02, 01:19 AM Thread Starter
Senior Tech
Marc
 
Join Date: Jun 2001
Location: Cedar Rapids, IA
Posts: 734
I just put in a new after market disc brake system in my 67 camaro along with a line lock/roll stop. I also have new rear brakes on my ford 9 inch. Everything is new, but the splitter. I bench bled the master cylinder and I have tried bleeding the brakes several times, but there are no brakes unless you pump them 6-8 times. Then they work. What might be the problem? Do I still have air in the system? If so, Any suggestions?
camaro man is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Aug 11th, 02, 02:23 PM
Senior Tech
 
Join Date: Aug 2000
Location: DULUTH, GA.
Posts: 917
Yep....air still there, and lot's of it. When you pump fluid, it compresses the air and finally they work. Try a vacuum bleeding system.

------------------
STEVE JACK
ConceptOne Pulleys and Brackets
Northern/Southern Rodder Magazine's "Jack'Stands" author and creator
Techical forum/links at www.inccn.net/techforum.htm
HOTRODSRJ is offline  
post #3 of 3 (permalink) Old Aug 11th, 02, 02:58 PM
 
Join Date: Mar 2002
Posts: 264
Check to make sure you installed the calipers on the correct side.The bleeder valve should be above the line to the caliper.

[This message has been edited by 67camss/rs (edited 08-12-2002).]
67camss/rs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome