NEED HELP PLEASE - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Mar 6th, 01, 08:42 PM Thread Starter
 
Join Date: Mar 2001
Location: WHITE PLAINS, NY
Posts: 14
Post

I instaled new presure switch(60psi)
and when i start my car oil presure gage in dash board show all 60
???
please help guys!
CAMARO Z28 1986
VladZ28 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Mar 7th, 01, 06:17 PM
Senior Tech
 
Join Date: Oct 2000
Location: Las Vegas, NV
Posts: 612
Post

So, are you concerned that the gauge is pegged? My autometer gauge reads around 72 psi when i start my LT1. If you could elaberate on the concern, i'd be glad to help.
Tyler

------------------
<A HREF="http://www.pro-touring.com/featured_cars/tyler_beauregards_68_camaro/tyler_beauregard.htm" TARGET=_blank>
68-LT1-T56
</A>
Teetoe_Jones is offline  
post #3 of 3 (permalink) Old Mar 8th, 01, 03:18 PM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,074
Post

There is a difference between a pressure switch and a pressure SENDER, make sure you have a new SENDER for use with your pressure gauge. They can look the same.
A switch would be used for an oil warning light.


------------------
Check my web page for First Gen Camaro suspension info:
David's Motorsports page
First Gen Suspension Page
67 RS 327
69 Camaro Vintage Racer
65 Lola T-70 Can Am Vintage Racer
davidpozzi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome