Demon carb - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Feb 7th, 03, 10:55 AM Thread Starter
 
Join Date: Nov 2002
Location: Ocoee, fl, usa
Posts: 4
I have a just of idle hesitation. Car tries and does die, when giving some gas on take off. Sometimes a very quick start will get past it. It is an auto.

It most like is the carb. But no luck so far with adusting the idle screws.
68flcamaro is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Feb 7th, 03, 11:22 AM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,547
Garage
Two ways to approach this. Change the accel pump cam to strech out the pump shot to cover the flat spot during transition off the idle circuit or install a larger squirter which will dump more fuel into the transition mixture. This may result in a pump cam change as well. Make sure the accl pump operates and squirts just as the throttle is moved first.

What happens is when you step on the gas large amounts of air get into the carb and intake faster than the gas gets there. You get a temp lean condition and the accel pump squirts extra gas to over come the lean condition.

I should have asked if this was a vac secondary carb as the secondaries opening too soon can cause the same symptoms. A heavier sec diaphram spring would be in order if this were the case.

------------------
...Dennis
"The '69, the '96 our local club"
and the "daily driver"
DjD is offline  
post #3 of 3 (permalink) Old Feb 7th, 03, 12:45 PM Thread Starter
 
Join Date: Nov 2002
Location: Ocoee, fl, usa
Posts: 4
This sends me in the right direction. They are mech secondaries by the way.

I just rebuilt the carb. So I might want to check the accel pump, to see if it is working properly.

I did not know you could change the cam, but I see kits are available.
68flcamaro is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome