injection problems - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Dec 8th, 00, 06:29 AM Thread Starter
 
Join Date: Dec 2000
Location: louisiana
Posts: 8
Angry

89 z-28 350 tpi, won't run unless primed first, runs fine after, fuel pressure fine, 12 volt at injectors. any suggestion
tuckstoy is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Dec 8th, 00, 06:53 AM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,073
Post

It might be a bad fuel pump relay. I think the oil pressure switch takes over after startup.
Do you have the OK fuel pressure when the key is first turned on before starting the engine?
David

------------------
Check my web page for First Gen Camaro suspension info:
David's Motorsports page
First Gen Suspension Page
67 RS 327
69 Camaro Vintage Racer
65 Lola T-70 Can Am Vintage Racer
davidpozzi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome