steering - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 22nd, 01, 06:07 AM Thread Starter
 
Join Date: Jul 2000
Location: Alpha Ohio US
Posts: 27
Question

Hi all
This is not for my Camaro but my daughters 85 S10. She had it towed here after breaking her ignition switch, and I replaced it (first time I've done that, and hopefully last). Everything went back together fine except for the horn. She had a friend helping her at the parking lot and they busted the wheel cover. Well, I lined up the wheel so it was straight with the tires and tightened everything up, then get a phone call from her last night and the wheel is now in the straight-up position (like a hard right turn). I know everything was tight... Did I miss something. Dont want her to loose the steering.
thanks
Bob
bob8748 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 22nd, 01, 03:35 PM
Gold Lifetime Member
Bruno
 
Join Date: Oct 2000
Location: Puerto Rico
Posts: 2,118
Post

Sometimes, when you install the steering wheel, it looks OK at first sight but you have to run the car in a straight road to really notice any missalignment. Ohh, but first, have it checked as soon as possible.
ORENCH is offline  
post #3 of 4 (permalink) Old May 22nd, 01, 04:53 PM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,124
Post

There should be a punch mark on the shaft to show the 12'oclock position, line the wheel up with that.
You have to look real close to see it.
David

------------------
Check my web page for First Gen Camaro suspension info:
David's Motorsports page
First Gen Suspension Page
67 RS 327
69 Camaro Vintage Racer
65 Lola T-70 Chev 350
Can Am Vintage Racer
davidpozzi is offline  
 
post #4 of 4 (permalink) Old May 22nd, 01, 07:49 PM Thread Starter
 
Join Date: Jul 2000
Location: Alpha Ohio US
Posts: 27
Wink

thanks guys, she is bringing it back Friday. Told her not to drive it much untill then, says it drives fine, wheel is just crooked. Will take off again, look for mark, then test drive it this time.
thanks again
Bob
bob8748 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome