Timing problem - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Apr 26th, 01, 10:04 AM Thread Starter
 
Join Date: Feb 2000
Posts: 101
Question

I have an Accel HEI in my 68 Camaro 350 motor and I had a bad vacuum advance so I swapped it out. I had 14 degrees initial timing before I changed it with the vacuum plugged, and now I am right at TDC after changing it with vacuum plugged. How is that possible?? The distributor clamp is tight so I know that the distributor did not turn. Any ideas?? This has happened twice now, both times after pulling the vacuum unit out and reinstalling.
rodsters is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Apr 26th, 01, 10:57 AM
Senior Tech
 
Join Date: Dec 2000
Location: Monroe, WA, USA
Posts: 312
Post

sound's like the old vacuum advance was hung and it left the advance part of the carb about 14* advanced. after you swaped in the new unit, you retarded the advance part and your base timing went lower.

plug the vacuum advance into the manifold vacuum and see if your timing come's up, this is a great way to see if it work's too, then unplug it and see where it is at. if it is back where it was when you started, set the base timing and go and have fun! if it is diferant i bet you might need to do some work to fix your distributor.


[This message has been edited by ilbl8 (edited 04-26-2001).]
ilbl8 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome