Cuts out at 90 - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jun 3rd, 00, 01:33 PM Thread Starter
 
Join Date: Jun 2000
Location: Fairbanks, AK USA
Posts: 3
My RS/SS 396 gets up to ninety and cuts out like it is not getting fuel. I have installed a GM Elec Ign, new wires, new fuel filter, plugs, etc. Basically tuned it up. On the analyzer, it runs perfect. My guess at this point is fuel pump. It has a mechanical now. I am considering an elec. the prev. owner had one...i don't know what. I have been told a 100 gph is the way to go. What do you think? Any reccomendations. The engine has 75000 original miles and runs fine until you punch it or run it up into the high 80's low 90's. Oh yeah, it has a rebuilt 4 barrel that has had the bowls punched out.

Thanks
malemute is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 3rd, 00, 08:03 PM
Senior Tech
Jim
 
Join Date: Apr 2000
Location: York S.C.
Posts: 1,081
My first guess, the valves are floating.

------------------
67 Camaro SS Conv.
70 Challenger R/T Conv.
ragtopman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome