1967 powerglide automatic transmission - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Mar 22nd, 99, 08:21 PM Thread Starter
 
Join Date: Mar 1999
Location: Richfield, MN US
Posts: 1
Im having trouble getting my tranny to shift out of park, except the tranny doesn't think its in park because the car will still roll, and if I put it up on jacks the rear tire spins like its in drive. Even though it seems like it might be in drive, when its on the ground and I try to accelerate the car doesnt move any faster then a rolling speed. I was also wondering if a turbo hydromatic off of a 77 350 ci suburban would bolt right up to the 327 ci engine in the camaro right now without any problems. Any info about the tranny or the tranny swap would be greatly appreciated. Thanks.
wiggins is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Mar 23rd, 99, 12:47 AM
 
Join Date: Feb 1999
Location: Waynesboro, PA, Franklin
Posts: 23
Wiggens,
A 350 turbo will bolt up to the car,
but you want to make shore that your tranny has a short tail shaft. The one you want to use probably has a long tail shaft. You need to get a 350 out of a car not a truck. Also once your swap is complete make shue to check your drive shaft for proper clearance. You should have 3/4 to an 1 inch of free travel on your tranny tail yoke.
GEAR HEAD is offline  
post #3 of 3 (permalink) Old Mar 23rd, 99, 12:47 AM
 
Join Date: Feb 1999
Location: Waynesboro, PA, Franklin
Posts: 23
Wiggens,
A 350 turbo will bolt up to the car,
but you want to make shore that your tranny has a short tail shaft. The one you want to use probably has a long tail shaft. You need to get a 350 out of a car not a truck. Also once your swap is complete make shue to check your drive shaft for proper clearance. You should have 3/4 to an 1 inch of free travel on your tranny tail yoke.
GEAR HEAD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome