Still rich - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jun 2nd, 02, 02:31 PM Thread Starter
AJ
Tech Team
 
Join Date: Dec 1999
Location: Salem,Oregon USA
Posts: 60
My small block was running very rich and fouling plugs after about 10 miles. Low vacuum(8"@1000 rpms).
Opened the seconary plates and then could idle down to 850 rpms and vacuum uped to 10". Idle screws then had no affect on idle or vacuum.
Cars ran very good but after about 25 miles, started acting like fouled plugs again. They were fouled but not as bad as before.
What else can I do.
331" with 9.4-1 compression, Sportsman II, Comp XE274, Holley street Dominator intake / 750 Vac Sec carb (80508) 5.5 power valve 70 jets in primaries and what ever is in the seconary metering block.
HEI with 12 initial 34 total all in @ 2800
Thanks AJ
AJ is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 2nd, 02, 02:37 PM Thread Starter
AJ
Tech Team
 
Join Date: Dec 1999
Location: Salem,Oregon USA
Posts: 60
forgot to add: Plugs AC R43 than R44 than R45
Any problem with AC's?
AJ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome