82 Camaro Z/28 Crossfire problems - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Mar 15th, 01, 02:10 PM Thread Starter
 
Join Date: Mar 2001
Location: New Jersey
Posts: 1
Unhappy

I brought a 82 Z/28 with crossfire and now it seems that it is just dumping fuel down the throttel bodies even at idle !!!any suggestions ?
Wired98 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Mar 15th, 01, 05:49 PM
Senior Tech
Dale
 
Join Date: Sep 2000
Location: Glendale,AZ.U.S.A.
Posts: 966
Post

Check the fuel pressure,computer coolant temp,and MAP sensor.The MAP needs to have manifold vaccum going to it.It's a 3 wire connector,small,black box.Usually mounted on firewall.Most likely,no vac to map sensor.Does it blow black smoke(tailpipe)?

------------------
68 z28 ,68 rs 327 ,73 454 vette, 2 goofy kids
dale68z is offline  
post #3 of 5 (permalink) Old Mar 17th, 01, 06:46 PM
 
Join Date: Mar 2001
Location: Gainesvillle, Florida u.s.
Posts: 5
Post

Welcome to the wonderful world of cross fire injection, I personally would throw the damn thing away but thats me i think i have rarely seen one work correctly for more than a year, anyhow oh i used to live in scottsdale, az hows the car shows here they call 5 cars getting together a car show.....
JOHNNY6 is offline  
 
post #4 of 5 (permalink) Old Mar 18th, 01, 07:42 AM
Senior Tech
 
Join Date: Dec 1999
Location: Meridian, Idaho
Posts: 321
Post

I have had no problems with my 84 Vette with crossfire injection. I have had it now 160,000 miles and 25 MPG.
camaroguy is offline  
post #5 of 5 (permalink) Old Mar 18th, 01, 07:09 PM
 
Join Date: Mar 2001
Location: madelia mn
Posts: 1
Post

i agree with johnny6 iv been an auto mech for about 10 years and have woked on about a dozen croosfires most are junk and can get expencive to repair hope u get evrything working

[This message has been edited by lest (edited 03-18-2001).]

[This message has been edited by lest (edited 03-18-2001).]
lest is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome