Knocking noise from motor. - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old Sep 14th, 03, 12:54 PM Thread Starter
 
Join Date: Jun 2002
Location: fremont,ca,u.s.a
Posts: 27
Thumbs down

Well I finnaly got done with the 454 project but now I am getting a strange niose. When the car is running there is a knocking and squeaking noise at the same time . The noise changes as I rev the engine or as I let in the clutch.It is pretty loud. The engine just had the heads redone and is farely fresh. What could be my problem here? [img]graemlins/clonk.gif[/img]
69ssCamaro4a17yrold is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Sep 14th, 03, 05:25 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Post

I've heard loose torque converters cause a concerning knock. Any chance the clutch didn't get sinched up good?

-dnult

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #3 of 9 (permalink) Old Sep 16th, 03, 05:03 AM
Senior Tech
Steven
 
Join Date: Jan 2001
Location: Raleigh, NC
Posts: 1,046
Post

I would take a look at the throw-out bearing as the source for the squeal. Also, did you install a new pilot bushing? If not, your tranny input shaft would have way to much room to move about and this is not a good thing ...
sdtsdt is offline  
 
post #4 of 9 (permalink) Old Sep 16th, 03, 06:39 PM Thread Starter
 
Join Date: Jun 2002
Location: fremont,ca,u.s.a
Posts: 27
Post

yea i replaced the bearing. So thats not it. I also have a 4 speed so I have no torque converter. Godd call though my dad just had that problem on his car and we fixed it. Mine on the other hand I dont no. could It be the pressure plate?
69ssCamaro4a17yrold is offline  
post #5 of 9 (permalink) Old Sep 16th, 03, 06:40 PM Thread Starter
 
Join Date: Jun 2002
Location: fremont,ca,u.s.a
Posts: 27
Post

yea i replaced the bushing.Not the pilot bearing thoe .
69ssCamaro4a17yrold is offline  
post #6 of 9 (permalink) Old Sep 17th, 03, 03:53 AM
 
Join Date: Jun 2003
Posts: 60
Post

sounds like you might have to bite the bullet and drop the pan to check the lower end and pop off the valve covers and check the rockers
gunny is offline  
post #7 of 9 (permalink) Old Sep 17th, 03, 02:22 PM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,073
Post

I had a friend with a 454 newly rebuilt, he had no oil to the left side rocker arms. I never found out why that happened. It was an early 80's engine.
There were little piles of metal shavings under each rocker!
David

Check my web page for First Gen Camaro suspension info:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

67 RS 327 original owner. 1965 Lola T-70
davidpozzi is offline  
post #8 of 9 (permalink) Old Oct 27th, 03, 04:29 PM
 
Join Date: Oct 2003
Location: chicago
Posts: 2
Post

my brand new 454 started knocking when i ran synthetic oil its an easy fix
ratmaro is offline  
post #9 of 9 (permalink) Old Oct 28th, 03, 07:01 AM
Senior Tech
 
Join Date: Apr 2000
Location: holliston, mass
Posts: 622
Post

clutch disk installed backwards???

have you tried running the engine without belt driven accy's connected??

good luck

John...
68ragtop is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome