1990 RS, possible electrical problem? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Feb 3rd, 01, 08:11 PM Thread Starter
 
Join Date: Feb 2001
Location: Charlotte, NC
Posts: 1
Unhappy

Sorry for any non-technical descriptions, I'm not too knowledgable in the vehicle area. I recently bought a 90 RS, and after driving it for about 3 weeks it started doing strange things. The previous owner replaced the original radio with a newer stereo, and it randomly looses power for a few seconds every now and then. Sometimes it looses everything it had in the memory (programmed channels, time, etc), other times it just comes back on and everything is fine. It also happens sometimes when I use the power windows.

The latest thing that happened is that the stereo lost power, then the speedometer jumped from 35mph to about 55 and at the same time the rpm gauge jumped and the infl rest light flashed a few times. Any idea what might be causing this? I would appreciate any ideas or suggestions, thanks.
TheCamgal is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Feb 4th, 01, 05:50 PM
Tech Team
 
Join Date: Jan 2001
Location: SO CAL.
Posts: 31
Post

I am not an expert electrical guy, but I would think it would be either a bad ground or the positive side of something could be grounding out. You should take it to a mechanic to be checked, because those cars are very much electrical and bad wiring in one of those can become very expensive if not fixed!!!

------------------
<UL TYPE=SQUARE> 67' Camaro 408" <LI>BBC, 598 HP. th400 3500 stall
<LI> 3.90 gears
<LI>best of 11.50 @ 118 MPH (Street Driven)[/list]
BRY67 is offline  
post #3 of 4 (permalink) Old Feb 14th, 01, 05:17 PM
 
Join Date: Feb 2001
Posts: 19
Post

I have had the same problem in my 90 RS/SS. The factory computer in those 90 models start going bad and everything electronic starts going haywire...mine started causing the transmission to act really funky. Take it to a good mechanic and get it checked right away, or you will starting having worse problems all over the car.

Good luck!

------------------
90 Camaro RS/SS project (email for questions)
SpeedRacerSS is offline  
 
post #4 of 4 (permalink) Old Feb 14th, 01, 06:00 PM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,461
Garage
Post

<BLOCKQUOTE>quote:</font><HR>Originally posted by SpeedRacerSS:
I have had the same problem in my 90 RS/SS. The factory computer in those 90 models start going bad and everything electronic starts going haywire...mine started causing the transmission to act really funky. Take it to a good mechanic and get it checked right away, or you will starting having worse problems all over the car.

Good luck!
<HR></BLOCKQUOTE>

Talk to me about a '90 SS!! I thought '72 was the last year until '96...

------------------
...Dennis
The Cars:
'69 RS Convertible w/SS trim
'96 Z28SS #1679 of 2410
The Club:
Camaros Limited Nor-Cal
DjD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome