Hesitation on high rpm - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Jan 15th, 01, 04:07 AM Thread Starter
fsr
 
Join Date: Dec 2000
Location: Lansing MI, USA
Posts: 15
Smile

The car hesitates on high rpm when over 3.000 rpm, the engine start without problems and runs fine in Park.

I don't have any codes and the light Service Engine Soon isn't on.

New EGR, Spark Plugs and wires, check valve, pcv valve, air pump, air filter, fuel pressure regulator.
(Camaro 1994 3.4 V6 103.000 Miles)

Any ideas?

Thanks for the help!

FSR
fsr is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Jan 15th, 01, 06:32 AM
Team Member
John
 
JohnZ's Avatar
 
Join Date: Sep 2000
Location: Washington, Michigan USA
Posts: 7,728
Post

Fuel supply restriction - check your fuel filter and lines and fuel pump pressure.

------------------
JohnZ
'69 Z28 Fathom Green
JohnZ is offline  
post #3 of 6 (permalink) Old Jan 15th, 01, 08:03 AM
Gold Lifetime Member
Rick
 
Join Date: Feb 2000
Location: Accord, NY
Posts: 4,815
Post

I had a similair problem and it was the fuel filter. Also, try some dry gas - can't hurt and you can be surprised how water can collect.
RickD is offline  
 
post #4 of 6 (permalink) Old Jan 16th, 01, 03:38 AM Thread Starter
fsr
 
Join Date: Dec 2000
Location: Lansing MI, USA
Posts: 15
Post

I put a new fuel filter, and the car it looks like better, but still hesitates when cold.

There is something else that I have to check?

Thanks!

FSR
fsr is offline  
post #5 of 6 (permalink) Old Jan 17th, 01, 05:36 PM
 
Join Date: Jan 2001
Location: halifax, nova scotia, canada
Posts: 7
Post

go for a drive watching the fuel pressure you will see a drop if the pumps bad. also we have seen a couple wear out the cam on a 3.4
(at the GM store)
drews70camaro is offline  
post #6 of 6 (permalink) Old Jan 18th, 01, 03:13 AM Thread Starter
fsr
 
Join Date: Dec 2000
Location: Lansing MI, USA
Posts: 15
Talking

Thanks!

I have a bad injector and I ordered a new kit.

See you in the highway...!

fsr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome