95 camaro 3.4 - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Dec 13th, 12, 04:32 PM Thread Starter
mike
 
Join Date: Dec 2012
Location: orlando
Posts: 7
95 camaro 3.4

Hi, so my car smokes white which i belive is water although it smells like gas. I no its running rich becaus my mpg is around 8. It studders slightly and pops at high rpm. Any advise??
mikester1210 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Dec 13th, 12, 08:46 PM Thread Starter
mike
 
Join Date: Dec 2012
Location: orlando
Posts: 7
Re: 95 camaro 3.4

Anyone... please.
mikester1210 is offline  
post #3 of 8 (permalink) Old Dec 14th, 12, 03:53 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,715
Garage
Re: 95 camaro 3.4

Welcome, Mike.
Off the cuff, running rich could mean the engine mgmt system is in choke mode,
I would probably check the two-wire coolant sensor to see if it is either unplugged or corroded, maybe an unplug and reconnect the connector.

You might measure across the coolant sensor terminals with an ohmmeter at both engine temperatures of cold and operating temp, ensuring the sensor reads less ohms at operating temp, and the harness still id connected to the ECM.

Also, the first check would be to the local Advance Auto and borrow the code reader to see if a code is set. Usually, the CHECK ENGINE light is on. Since you did not mention the CEL, I suspect it is not on, or burned out. There si a CEL bulb check when ign is in IGN position, then the light goes out.

Could be a leaky injector, Run a can of injector cleaner with the next full tank.
Air filter could be clogged also and in need of changing.

You might buy a Haynes manual and read up.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden … enjoy your next chapter.
Everett#2390 is offline  
 
post #4 of 8 (permalink) Old Dec 14th, 12, 01:04 PM Thread Starter
mike
 
Join Date: Dec 2012
Location: orlando
Posts: 7
Re: 95 camaro 3.4

My fan dosent come on. I bought the new coolant temp sensor and installed it, but fan still dosent come on. I dnt no why... I ran injector cleaner and even seafoam. I think the fan not comming on is a good place to start because correct me if im wrong, the temp sensor should turn the fan on.
mikester1210 is offline  
post #5 of 8 (permalink) Old Dec 14th, 12, 01:06 PM Thread Starter
mike
 
Join Date: Dec 2012
Location: orlando
Posts: 7
Re: 95 camaro 3.4

Also the light comes on for a min when i put the key in but goes out. If i let off the gas pedal in gear some times it comes on but goes out after i start it back up.
mikester1210 is offline  
post #6 of 8 (permalink) Old Dec 14th, 12, 03:39 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,715
Garage
Re: 95 camaro 3.4

Fan is controlled by the PCM, Power Control Module, at two events, 1) engine coolant above 235°F, one fan, and when MAX A/C is selected, both fans, if equipped with two.
CEL coming on & off is good bulb check at turning ign sw to IGN before START.
However, CEl coming on at decel is a problem and may set a trouble code.
As suggested, go to an auto parts store and borrow code reader to find trouble code set. Then look up trouble code(s).

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden … enjoy your next chapter.
Everett#2390 is offline  
post #7 of 8 (permalink) Old Dec 15th, 12, 11:19 AM Thread Starter
mike
 
Join Date: Dec 2012
Location: orlando
Posts: 7
Re: 95 camaro 3.4

Ive tried autozone but this year has a obd1 comp n obd2 connection. Says no link. Fan dosent even come on with ac on.
mikester1210 is offline  
post #8 of 8 (permalink) Old Dec 17th, 12, 05:05 PM Thread Starter
mike
 
Join Date: Dec 2012
Location: orlando
Posts: 7
Re: 95 camaro 3.4

Someone help me please. This is my dd and its costing way to much to drive my baby...

An inch or a mile, winning's winning
mikester1210 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome