SES Light on - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Dec 29th, 12, 04:42 PM Thread Starter
Jackie
 
Join Date: Dec 2012
Location: Los Angeles, Ca
Posts: 1
Post SES Light on

I have a 1994 Camaro Z-28; I purchased it with blown head gaskets not knowing how many other things was wrong but over a few weeks an hour at a time I found out.
After I redid the heads, I added a water pump, plugs and wires, radiator, thermostat. I started it and it ran very well but the SES light came on and stayed on. I don't have the tools I use to have for testing so I had to go it the old way.
I did this in hope to help other with an SES light on and off and a failed smog test.
I tested the EGR valve and it was frozen so I installed a new one, $54., I tested the two AIR Valves both were junk so I replaced them but the light stayed on. I removed the AIR Pump and tested it and found the motor was frozen so I took it apart and cleaned it and now it work perfect. I figured if I have to replace it, it won’t matter if it is damaged or not, it was easy to get apart, the engine light went off after this repair.
I went in for smog and got a High HC read out. I went back in and checked the entire vacuum and found one on the EGR to port was backwards, my mistake. I then made sure the intake was clean, I did that when it was off but rechecked it. I checked the Map sensor and cleaned it, I also found the Air Intake tube was not fitting as well as it should so I replace it. The engine ran smooth but had a little tick to it and I knew something was wrong in the ignition system. I pulled the spark plugs and examined each one as I pulled them, I found the #7 was cracked under the gap area and it was jumping fire, I installed another set of plugs and it smooth out. I went back for the smog test and the reading dropped considerable but it did not pass. I checked the cat converter and found it was broken so I replaced it, I went back in for smog and it passed like a new car.
Lemon Protection is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Dec 29th, 12, 05:17 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,709
Garage
Re: SES Light on

If OBD1, you can place the ECM into diagnostic mode by shorting Pins A & B together with a paper clip and read the CEL flashes, key on, engine off.
First set of flashes should be flash, space, flash, flash, = 12, ECM okay and ommunicating. fl, fl, fl, space, fl fl, fl would equal 33, and so on.
It should flash each diag trouble code three times per trouble code, then start over with 12 and repeat.
Then go to the OBDI site and find the code problem.
Also during diag mode, the ECM commands the IAC to seat against the port, EGR solenoid open and charcoal purge open. Pull the IAC connector leaving it seated, undo the diag short, start engine and you can set base idle and unplug ECM bypass to set initial timing, or not, since you have a LT-1, but you can set idle, if needed.
After these are done, reconnect everything, pull a battery cable for about 15 seconds, reconnect cable, turn ign on, engine off for about 125 secionds to let ECM set IAC idle, then turn off ign for 10 seconds. Then start engine normally. It will take time and drive a few miles, including WOT for ECM to learn engine parameters for better running. ECM should control idle rpm even with a load/gear selected.

By puilling off battery cable completely resets the ECM.
If the above is not done, ECM will monitor the fault and if not appearing for the next 50 starts, then DTC will be erased.

Welcome to the Club, Pete. Good job in working on your '94 Z28 and to get it to pass CA emissions. You will be nabbed for pictures, just a warning for you.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden … enjoy your next chapter.
Everett#2390 is offline  
post #3 of 3 (permalink) Old Dec 31st, 12, 08:50 PM
Senior Tech
mike
 
Join Date: Sep 2007
Location: hopewell jct
Posts: 677
Re: SES Light on

we actually used a key like this back in the day ...
twozs is offline  
Sponsored Links
Advertisement
 
Reply

Tags
engine, light, power, ses, smog

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome