LOOSE STEERING 95 T/A - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Sep 19th, 00, 04:23 PM Thread Starter
 
Join Date: Sep 2000
Location: WESTVILLE NJ USA
Posts: 13
Red face

I have a 1995 trans am. The problem is when driven it fades just slightly. I have replaced the rack and pinnion,tie rod ends,alignment done, replaced steering coupler. You can feel when driven both wheels move when you hit a crack in the road.My 86 trans am had very tight steering, but this 95 wants to wander. Thanks for any info.
mike S is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Sep 19th, 00, 05:45 PM
Tech Team
 
Join Date: Aug 2000
Location: ,mi,USA
Posts: 94
Post

was this car wrecked? if it was you might want to check the body mounts.
DEVIL'S LAKE is offline  
post #3 of 3 (permalink) Old Sep 20th, 00, 06:02 AM Thread Starter
 
Join Date: Sep 2000
Location: WESTVILLE NJ USA
Posts: 13
Post

<BLOCKQUOTE>quote:</font><HR>Originally posted by DEVIL'S LAKE:
was this car wrecked? if it was you might want to check the body mounts.<HR></BLOCKQUOTE> Thanks that did it. Never thought of body mounts.

mike S is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome