Heater? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Nov 14th, 99, 02:57 PM Thread Starter
 
Join Date: Nov 1999
Posts: 1
I have an 89 IROC and the heater is not working. The car runs at normal temperature. I have replaced the heater valve, flushed the system, and replaced the thermostat. There is still no heat. I have checked my damper doors and they all seem to be in proper working order. It seems to blow warm at times, but surely not hot. If you know what my problem is, please E-mail me at [email protected]. Thank you for your time and help.
GrimReape2 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Nov 18th, 99, 11:41 AM
 
Join Date: Oct 1999
Posts: 217
Almost sounds like a plugged up heater core. Can you verify the flow to the core itself ?, If the rest of the coolong system is operating properly this may be a possibility. I'm not sure how the newer cars like yours are, but I know the older ones like mine were susceptable to clogging and corrosion that reduced effectiveness. I'm in the process of replacing the core in my 69.
Shawn is offline  
post #3 of 3 (permalink) Old Nov 22nd, 99, 07:51 PM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,081
Most GM heaters have a door that opens and diverts air from the heater core to the inside.
Frequently a pen or other object gets dropped into the defroster outlet and jams the door. Some doors are controlled by a vaccum actuator and a hose gets disconnected or there is a leak or pinched hose.
davidpozzi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome