Curberator torture!!help - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Apr 4th, 02, 02:08 PM Thread Starter
 
Join Date: Nov 2001
Location: Dayton Ohio U.S.A
Posts: 29
I can not figure out what is wrong my my 67 camaro with a 327. Since i had a edelbrock performer and 650 holley installed, It will not run right at all. It runs rich all the time, I've tried getting it tuned, but they cant stop it from running rich, itfloods after 10 minutes or so, and unless i idle extremely high, i lose oil pressure. I just recently found out that the parts that were put on are used, and came out of a hot rodded s-10. I believe possibly the jets could have been changed. Any idea's on what could possibly be the cause of this, and any possible solutitons.
David Bryant is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 7th, 02, 09:04 AM
Senior Tech
 
Join Date: Mar 2000
Location: Dtown PA
Posts: 820
if its running too rich, then it was not tuned correctly, you should have smaller jets i can garuntee, stock jets are around 65's for a 650-750's , I have 72's and a size 36 squirter, but that depends alot on whats in the engine, if its just a stock build 327, a 650 with stock jets will do you fine. it shouldnt run rich with the correct size jets installed.

Chris Edwards is offline  
post #3 of 3 (permalink) Old Apr 7th, 02, 07:59 PM
Senior Tech
 
Join Date: Aug 2000
Location: seattle, wa
Posts: 172
Hows the fuel pressure? It should be no higher than 6psi for Edlebrock. How about a vacuum leak? Floats?

------------------
Stock 67 327 RS
www.angelfire.com/ca7/goatjjcamarors/index.html
goatjj is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome