What did she do? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Jan 19th, 02, 11:17 AM Thread Starter
 
Join Date: Jan 2002
Location: ROSAMOND,CA. USA
Posts: 2
Angry

Hope someone can help.My wife knocked car into neutral with cruise on at about 70.When she got off fwy. car was knocking and running rough.Knocking seems to be from front of block.Any advice or opinions.
Car is a '90 iroc 5.7 auto.
Thanks Turbo
turbo is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Jan 19th, 02, 12:34 PM
Senior Tech
Dave
 
Join Date: Sep 2001
Location: Yorkville In
Posts: 1,420
Post

Hope your setting down, it sounds like it spun a rod bearing or threw a rod thru the side of the engine block.
Branded is offline  
post #3 of 8 (permalink) Old Jan 19th, 02, 06:02 PM
Senior Tech
 
Join Date: May 2001
Location: Ashby,MN, USA
Posts: 8,305
Post

the wife did it, huh? yeah, right


------------------
1971 Nova(looks like 69 camaro from underneath!)
355sb, vortec heads, HOT cam,T-10 tranny, 3.70 gears 16X8" IROC wheels
see pics here http://community.webshots.com/user/novaderrik
novaderrik is offline  
 
post #4 of 8 (permalink) Old Jan 20th, 02, 04:37 PM
Senior Tech
 
Join Date: Mar 2001
Location: slaughters ky 42456
Posts: 238
Lightbulb

Buy her a MSD 6AL with a 3000 RPM rev limit chip,just in case she doe's it again. Do this after installing the new engine.

------------------
69 Camaro SS 350 4 speed
86 Monte Carlo SS
gene stills is offline  
post #5 of 8 (permalink) Old Jan 21st, 02, 03:13 AM
Senior Tech
 
Join Date: Aug 2001
Location: Port Lavaca, TX
Posts: 127
Post

My cruise control cuts off if I take it out of gear. What really happened.
ryanman250 is offline  
post #6 of 8 (permalink) Old Jan 22nd, 02, 12:55 AM
Senior Tech
Steven
 
Join Date: Jan 2001
Location: Raleigh, NC
Posts: 1,046
Post

did you check the dipstick? I am sure you did ... Any oil ??? oil pressure ??? Just oil ??? The cruise control should disengage the moment the rpms shoot up ... did the car overheat ??? What is coolant level like ??? Check every possibility before committing to new engine ...
sdtsdt is offline  
post #7 of 8 (permalink) Old Jan 23rd, 02, 04:06 PM Thread Starter
 
Join Date: Jan 2002
Location: ROSAMOND,CA. USA
Posts: 2
Exclamation

OK SHE BENT SOME VALVES,PUSH RODS.BOTTOM END LOOKS GOOD.
THANKS
turbo is offline  
post #8 of 8 (permalink) Old Jan 25th, 02, 07:08 AM
Senior Tech
Matt Jones
 
Join Date: Jan 2002
Location: Renton, WA USA
Posts: 2,765
Post

The pistons that the valves hit may not look too good!

------------------
1969 Base Camaro
Vortec 350, TH-400
All sheetmetal is NOS GM
Silver69Camaro is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome