bad idle - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old May 7th, 03, 06:09 AM Thread Starter
 
Join Date: Nov 2002
Location: Pompano Fl USA
Posts: 15
Unhappy

90 IROC-Z 305 TPI. Every time I pull up to a red light and start to idle at around 900RPM the car has one little shake drops to about 600RPM then back up to 900 again like every five seconds . I figured it was the timing belt but its not and I checked comppersion, checked fuel pressure, did everything I could think of even cleaned the cat out.
3.73 rear end
High performance cam (Is idle time to low)
K&N air filter
High comp head
Performance chip
(only upgrades made)
allinallcamaro is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old May 7th, 03, 06:45 AM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Post

Try cleaning the throttle body, IAC pintle and passage.

Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline  
post #3 of 6 (permalink) Old May 7th, 03, 11:29 AM
Senior Tech
 
Join Date: Mar 2003
Location: fairfield, Ca
Posts: 175
Post

Does it do this with the a/c off?

67RS-zz4 w/ trickflow heads 276hr cam air gap 780 Pro Systems TexRacing 4spd AGR steering SCAT procars 12 bolt eaton posi 3.73's SSBC all around, TT2's Dakota Digital Painless DSE hinges


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mike's67 is offline  
 
post #4 of 6 (permalink) Old May 7th, 03, 04:01 PM Thread Starter
 
Join Date: Nov 2002
Location: Pompano Fl USA
Posts: 15
Post

The ac is off.
allinallcamaro is offline  
post #5 of 6 (permalink) Old May 8th, 03, 01:17 PM
Tech Team
 
Join Date: May 2001
Location: Goose Creek, SC
Posts: 44
Post

Fuel filter?
wplax26 is offline  
post #6 of 6 (permalink) Old May 9th, 03, 06:05 AM
TRT
Senior Tech
 
Join Date: Sep 2002
Location: USA
Posts: 107
Post

Possibly EGR valve sticking

The voice of dissent
TRT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome