what's that smell???? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Apr 28th, 01, 11:29 AM Thread Starter
Senior Tech
 
Join Date: Jan 2001
Posts: 251
Post

Well friday I was driving down the road and I make a left hand turn and half way through this I start see smoke coming from column and maybe dash right above it. Then I start smelling something frying. I pulled over right away and it quit. Looked under the dash I didn't see anything right there but...anyhow later during the day I go to use my turn signal and it was acting funny so I'm guessing I fried the switch or a relay or something. The right hand turn signal stays on (on the gauge) and the left blinks real fast. Any thoughts on what to look for?

Also about an hour before this happened the horn grew a mind of it's own (after I honked at an old lady that almost hit me in a turn) so I disconnected it.
67stock is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Apr 28th, 01, 03:16 PM
 
Join Date: Mar 2001
Posts: 24
Post

I think it might be the wire harness that runs in the steering column, but first just take the steering wheel off and see if there is any wires gounding out when you use the turn signals. Try to jiggle wires around to see if this has any effect. Does your emergency flashers work? The wires for the horn,turn signals and emergency flashers follow the steering column. You should see what looks like a ribbon with about 4? or 5? wires with a connection at the end of it. You will have to take the steering wheel off,turn signal lever off and emergency flasher switch off.There are some screws also(this happened on a 1970 chev.truck since its been about 20 years ago that this happened to me, I dont remember all the details, it probably is different on yours....the wire ribbon was brittle and it cracked grounding them).I think the wires and the turn signal thats inside the column is(all one piece,but Im not sure). Im sure I missed other things about how to dissemble.Even though this happened on a 70 Chev.truck I hope this helps in some way.

------------------
1981Z28 1969Caprice396 1981TransAm Nascar Pace Car

[This message has been edited by TJMZ288 (edited 04-28-2001).]
TJMZ288 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome