Starting Troubles - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jun 19th, 01, 07:45 PM Thread Starter
 
Join Date: Jun 2001
Location: Red Deer, Alberta, Canada
Posts: 3
Question

I have a '67 camaro with a mild to moderate 327. I am having a starting problem, lots of fuel with new AC Delco electric pump but no spark. The distributor is brand new, it has an MSD under the cap coil. The cap and rotor are also new. There is power at the BAT connection. Anybody with an idea as to what else I can check. It doesn't get much simpler than an HEI setup so I'm stumped. Any help would be appreciated.
thillman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jun 20th, 01, 12:59 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,005
Garage
Cool

Disassemble the coil/cap, Makes sure the grd wire is tied in with the coil holddown screw.

Check also for the spring(?) between the coil output and the cap's spring-loaded center conductor going to the rotor.

If you have an original HEI distributor, then buy a cheap replacement module and subsitute for the MSD, just to see if it runs, could be MSD is broke.

Everett 68/350/PG/11.90/115mph
Everett#2390 is offline  
post #3 of 4 (permalink) Old Jun 20th, 01, 10:42 AM Thread Starter
 
Join Date: Jun 2001
Location: Red Deer, Alberta, Canada
Posts: 3
Post

Thanks Everett

This is a brand new distributor, the old one didn't work either. Its an MSD coil that worked before I disassembled it to install a new intake. Whats the best way to test the coil?

Thanks
thillman is offline  
 
post #4 of 4 (permalink) Old Jun 21st, 01, 01:29 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,005
Garage
Cool

HEI coil? Measure primary and secondary resisitance with a Digital Voltmeter, Pri=<30 ohms, Sec = 10k-15k ohms.

Everett

Everett#2390 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome