TURN SIGNALS DONT WORK?? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Mar 10th, 03, 02:43 PM Thread Starter
 
Join Date: Mar 2003
Location: PORTLAND
Posts: 3
Post

Have a 68 rs camaro and I am having a problem with the turn signals.. I started with a 4spd car and restored to an auto. I have all new wiring for car including the gauge package. I have a new ac delco turn signal switch and it does not work? The hazzards work but the turn dont?? Is there a flasher issue/or?? Please help..[LIST]
MAKMANIA is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Mar 11th, 03, 10:37 AM
Senior Tech
Tom
 
Join Date: May 2001
Location: Socorro, New Mexico, USA
Posts: 574
Send a message via MSN to kausboy
Post

Usually you have a seperate flasher for hazard lights. My guess is a bad flasher. I say that because if the hazards are working the main circuit is working. The problem has to be either in the switch or the turn signal flasher itself. When you say it doesn't work do you mean no lights at all? Make sure you have power to the switch and make sure it isn't just a blown fuse! Good luck!
kausboy is offline  
post #3 of 3 (permalink) Old Mar 11th, 03, 03:35 PM Thread Starter
 
Join Date: Mar 2003
Location: PORTLAND
Posts: 3
Angry

Thank- [img]graemlins/beers.gif[/img] you for info..! I did not know there was a seperate flasher for the turn signals. I thougtht the pigtail was for the radio unit which was next in my journey of this car.
MAKMANIA is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome