lean exhaust - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Feb 23rd, 03, 11:36 AM Thread Starter
Tech Team
 
Join Date: May 2001
Location: Goose Creek, SC
Posts: 44
Post

I haven 87 z-28 with a 5.0L v8 in which the throttle linkage kept sticking, so that i had to "tap" the gas to keep the RPM's down. One day after driving for a couple miles i tapped it, and it just fell to crap. The engine now stall if i don't press the gas down, and intially while pressing the gas pedal it will die and then shoot up. I would think these are the symptoms of a vacuum leak. I can not visibly see any holes in the manifold gaskets, and all tubes appear to be in place. The service code came up as 44 which is "lean exhaust". Should i replace the O2 sensor? gaskets? fuel canister? air pump?

Black 1987 z-28 TPI<br />93 350 Caprice LO5<br />Edelbrock TES headers<br />dynomax superflow CC
wplax26 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Feb 23rd, 03, 11:55 AM
Senior Tech
 
Join Date: Nov 2002
Location: Aiea, Hawaii
Posts: 571
Post

2003-1987=16yrs. Clean and adjust the likage. 70 usages of the throttle per day 70X365=25550 with 13 years 25550X13= 332150 usages. Have you ever cleaned, adjusted or PMCSed the linkage? There is more than a go linkage to care for. Normally when something is sticking it means something is out of line, jammed or rusted up or even a retainer clip is off causing a problem. There have been wonderful plastics added to some year issues of intakes where the plastic cruds out and drops off some place. In some cases for automatics it's a death sentence since the plastic also relates to a linkage for clutching in the trans and the trans burns up some stuff. Merry christmas. Your best luck would be having pictures to compair your linkage to. Also do a recall check for the linkage problem of plastic bushings or retainers. It seems it was industry wide. Good luck.
Snatchin'gears is offline  
post #3 of 4 (permalink) Old Feb 24th, 03, 03:47 PM Thread Starter
Tech Team
 
Join Date: May 2001
Location: Goose Creek, SC
Posts: 44
Post

Thank you, however, my question was what could be causeing my car to run so badly? Where are the key places to check for a vacuum leak? Could it be a head gasket?
wplax26 is offline  
 
post #4 of 4 (permalink) Old Feb 24th, 03, 05:45 PM
Senior Tech
 
Join Date: Nov 2002
Location: Aiea, Hawaii
Posts: 571
Post

One of the things about the computer memory of trouble codes is it will hang onto problems till they are taken off of the memory. If it is your diagnosic tool try making sure the memory is erased in the car and see if lean exhaust shows up again.
If it's a vacume leak that's so bad it's detremental to the engine performance you might try momentary closing off the intake with your hands and listening for a whistle where the leak is.
Good luck and check your plugs for being burned out since you got an error code for lean. I'm lost for what you have to work on or what the problem is. Carb EFI automatic trans?
Yes it could be youre head gasket.
Snatchin'gears is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome