91 Camaro Braking problems...need help - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jan 13th, 01, 08:36 PM Thread Starter
 
Join Date: Jan 2001
Location: Yorktown, VA, USA
Posts: 9
Post

During hard braking stops my car pulls hard to the right. I have disc in front/Drums in rear. I have replaced the rotor, pads, drum, and shoes to no avail. Please Help!

Thanks!
Matt
91 RS 305 TBI
Matt E is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jan 14th, 01, 04:38 AM
Senior Tech
 
Join Date: Jan 2001
Location: skiatook, ok
Posts: 3,692
Post

You may not have a brake system problem...you alignment could be off, you might have a tire going bad (cords seperating) or possibly a worn steering/suspension component. Also, make sure your wheel bearings are adjusted correctly...if one side is set tighter than the other, then that brake will "kick in" before the other does.

------------------
375hp 78 Chevy truck
77 Chevy Nova
95 Chevy Lumina 3.4L
and building a 78 Nova
travis is offline  
post #3 of 5 (permalink) Old Jan 14th, 01, 07:01 AM
Senior Tech
William
 
William's Avatar
 
Join Date: May 2000
Location: Waukesha WI
Posts: 2,938
Post

My '89 did this until both front brake hoses were routinely replaced during a suspension rebuild. Do the rear also while you're at it.
William is offline  
 
post #4 of 5 (permalink) Old Jan 16th, 01, 04:06 PM
 
Join Date: Jan 2001
Location: halifax, nova scotia, canada
Posts: 7
Post

sounds like the left front flex hose to me
drews70camaro is offline  
post #5 of 5 (permalink) Old Jan 17th, 01, 10:29 AM
Senior Tech
 
Join Date: Mar 2000
Location: Dtown PA
Posts: 820
Post

your brake hoses are bad. they may not look it, but they are collapsing in on themselves internally, I went through all the same headache, new rotors, calipers, pads, blah blah blah, If i would have just spent the 16 bux to replace the hoses I could have saved alot of money...

------------------
Chris's 67 RS can be seen at http://www.67rs.com
JOIN THE CAMARO NET WEBRING!
http://nav.webring.yahoo.com/hub?ring=camaronet&list
Chris Edwards is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome