Head Gasket - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Oct 8th, 01, 03:00 PM Thread Starter
Senior Tech
 
Join Date: Jul 2001
Location: Atlanta, Ga
Posts: 126
Post

I have a 305 w/ approx 183k miles....it was running warm to hot for a while..then finally the water got into the oil. Was it the head gasket? I took the heads off and there was no obvious problem with them. I got brand new heads and am about to put them on. But i was trying to make sure that was the problem. Could it be a cracked block, nothing was leaking by the way. Thanks
atldc is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Oct 8th, 01, 04:24 PM
Senior Tech
 
Join Date: Jan 2002
Posts: 505
Post

Have the old heads pressure tested and checked for warpage.
cavemate is offline  
post #3 of 3 (permalink) Old Oct 8th, 01, 04:55 PM Thread Starter
Senior Tech
 
Join Date: Jul 2001
Location: Atlanta, Ga
Posts: 126
Post

I've already exchanged them for brand new ones...
atldc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome